viernes, junio 27, 2008

Colorear área entre dos líneas en gráfico de Excel

Si queremos colorear el área comprendida entre dos líneas en un gráfico de Excel, podemos hacerlo usando algunos trucos sencillos.
La idea es construir este gráfico



Empezamos por construir un gráfico de líneas con, por ejemplo, estas dos series de datos



El gráfico resultante, después de hacer algunos arreglos cosméticos, es este



El primer paso es construir una columna auxiliar que calcula la diferencia entre los valores de las series



Nuestro próximo paso es agregar la Serie 2 al gráfico, pero con el tipo Área. Seleccionamos el rango B2:B13, lo copiamos (Ctrl+C); seleccionamos el gráfico y abrimos el menú Edición-Pegado Especial



La nueva serie es agregada como línea. Seleccionamos la serie y cambiamos el tipo de gráfico Área



Hacemos lo mismo con la serie de valores Auxiliar (C2:C13)



Finalmente, seleccionamos el primer área que hemos agregado al gráfico (con los valores de la Serie 2) y abrimos el menú de formato de serie de datos. En la pestaña Trama cambiamos las definiciones de Área y Borde a "ninguno"



El resultado es el siguiente

14 comentarios:

Albertovic dijo...

Muchas gracias. Ha sido de gran utilidad.

Bisimbre dijo...

Enhorabuena de nuevo Jorge por este magnífico trabajo.
Quisiera preguntarte si es posible que cambiara a un color diferente el área cuando la serie 1 tuviera un valor inferior a la serie 2.
Gracias por todo

Un saludo desde Zaragoza, España

Jorge L. Dunkelman dijo...

Hmmm, si se trata de todos los datos de la serie, es decir, todos los valores de la serie 1 son menores que los de la serie 2, puede hacer programando un evento (macro). Puedes fijarte en la nota sobre formato condicional de gráficos circulares.
Si tratamos de hacerlo punto por punto, el problema es más complicado. Tendría que estudiar la solución, si es que existe.

Anónimo dijo...

Sos un grosso!

klop dijo...

Tengo un prblema relacionado con uno de tus tutoriales

http://jld-excel-grafico.blogspot.com/2006/11/graficos-excel-dinamicos-determinando.html

Tengo una celda en la que está recogido un rango de valores (por ejemplo en C3 escribo =A1:A10), sin embargo, cuando le doy a dibujar esos valores sólo me dibuja el primero de ellos (A1), ¿que puedo estar haciendo mal?

Un saludo, muchísimas gracias por esta excelente página y disculpa si estoy haciendo la entrada en donde no debiera, me daba miedo que no leyeras comentarios a posts muy antiguos.

Juan

Jorge L. Dunkelman dijo...

Hola,

siempre me leo todos los comentarios, aunque no siempre tengo tiempo de responder.
En tu caso lo mejor sería que me mandes el archivo con el problema para que pueda analizarlo.

Juan Carlos dijo...

Gracias Jorge,

tengo una pregunta, qusiera hacer un gráfico de columnas apiladas en el cual pueda mostrar diferentes columnas apiladas para cada año. Es decir, para el año 2005 tengo que apilar , por ejemplo, ventas de producto A y ventas del producto B presupuestadas. Además para ese año tengo que apilar (en el mismo gráfico) las ventas de A y B reales. El gráfico debe incluir esto para los años 2005, 2006, 2007 y 2008.

Gracias,

Juan Carlos

Jorge L. Dunkelman dijo...

Hola Juan Carlos

mandame el archivo con los datos (o un ejemplo) al mail. La respuesta excede el alcance de un comentario.

Albertinho dijo...

Hola Jorge!

Es posible hacer un gráfico de líneas pero en vertical?

Tengo un gráfico de barras horizontales y cuando pincho en cada barra y elijo tipo de gráfico para que se vuelvan líneas, no aparecen en vertical sino en horizontal y cambia la escala.

Muchas gracias de antemano!

Albert

Jorge L. Dunkelman dijo...

No tengo claro lo que quieres hacer. Al pasar de un gráfico de barras a uno de líneas lo que se modifica es la representación de los datos, así que la escala no tendría que cambiar.
Puedes enviarme el archivo con un descripción de lo que quieres hacer.

Anónimo dijo...

Jorge, muchas gracias por tu página que me ha ayudado en varias ocasiones. Te voy a hacer una consulta:
cuando una celda contiene un vínculo a otra o una fórmula, si en la celda original no hay nada, en el vínculo pone 0. Yo esto lo soluciono poniendo un
=SI(P9>5;PROMEDIO(N2:N9);" ")
El problema aparece al hacer un gráfico, esos datos me los toma como 0 .¿qué puedo hacer?
Gracias de antemano
Saludos
Leonor

Jorge L. Dunkelman dijo...

Hola Leonor

tenés que modificar un poco la fórmula. Usa esta

=SI(P9>5;PROMEDIO(N2:N9);NOD())

Rubén dijo...

Jorge, te comento que uso planillas de cálculo desde hace mas de 20 años (siempre fuí fanático de Qpro) pero lo tuyo es fabuloso. Te felicito y espero usar tus soluciones en el futuro.
Gracias
Rubén Villodas
Mendoza - Argentina

Jorge L. Dunkelman dijo...

Rubén

gracias por los conceptos. Te comento que en mis primcipios también trabajé con Qpro, del cual tengo nostalgias hasta hoy.
Te sugiero que visites también mi blog sobre Excel.